safemode: org.apache.hadoop.security.AccessControlException: Access denied for user root. Superuser privilege is required

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

safemode: org.apache.hadoop.security.AccessControlException: Access denied for user root. Superuser privilege is required

shujamughal
Hi
I am trying to turn off the safe mode using the following command.

 hadoop dfsadmin -safemode leave

but it giving me this error. Anybody here to tell the solution?
Thanks in advance

--
Regards
Shuja-ur-Rehman Baig
<http://pk.linkedin.com/in/shujamughal>
Reply | Threaded
Open this post in threaded view
|

RE: safemode: org.apache.hadoop.security.AccessControlException: Access denied for user root. Superuser privilege is required

Michel Segel

Try running this as user hadoop or hdfs. (Depending on which version you are running.)

You need to do this on the name node.

If you're root ...
# sudo -u hdfs /bin/ksh


And yes, the fact that I'm still using ksh means I've been around long enough to remember AT&T Unix Sys V. ;-)


> Date: Sat, 6 Nov 2010 22:57:00 +0500
> Subject: safemode: org.apache.hadoop.security.AccessControlException: Access denied for user root. Superuser privilege is required
> From: [hidden email]
> To: [hidden email]
>
> Hi
> I am trying to turn off the safe mode using the following command.
>
>  hadoop dfsadmin -safemode leave
>
> but it giving me this error. Anybody here to tell the solution?
> Thanks in advance
>
> --
> Regards
> Shuja-ur-Rehman Baig
> <http://pk.linkedin.com/in/shujamughal>