CVE-2018-11767: Apache Hadoop KMS ACL regression

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

CVE-2018-11767: Apache Hadoop KMS ACL regression

Akira Ajisaka-2
CVE-2018-11767: Apache Hadoop KMS ACL regression

Severity: Severe

Vendor: The Apache Hadoop Software Foundation

Versions affected: 2.9.0 to 2.9.1, 2.8.3 to 2.8.4, 2.7.5 to 2.7.6.

Description:
After the security fix for CVE-2017-15713, KMS has an access control regression,
blocking users or granting access to users incorrectly, if the system
uses non-default groups mapping mechanisms such as LdapGroupsMapping,
CompositeGroupsMapping, or NullGroupsMapping.

Mitigation:
Users should upgrade to Apache Hadoop 2.7.7, 2.8.5, or 2.9.2.

Credit:
This issue was discovered by Wei-Chiu Chuang.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]